Jump to content

  • Log in with Facebook Log in with Twitter Log In with Google      Sign In   
  • Create Account

Welcome to BZPower!

Hi there, while we hope you enjoy browsing through the site, there's a lot more you can do if you register. The process is easy and you can use your Google, Facebook, or Twitter account to make it even faster. Some perks of joining include:
  • Create your own topics, participate in existing discussions, and vote in polls
  • Show off your creations, stories, art, music, and movies and play member and staff-run games
  • Enter contests to win free LEGO sets and other prizes, and vote to decide the winners
  • Participate in raffles, including exclusive raffles for new members, and win free LEGO sets
  • Send private messages to other members
  • Organize with other members to attend or send your MOCs to LEGO fan events all over the world
  • Much, much more!
Enjoy your visit!


Issue Information

  • #000041

  • Issue

Issue Confirmations

  • Yes (0)No (0)
Locked 
Photo

Emoticons in older blog entries

Posted by fishers64 on Nov 18 2012 - 11:11 PM

In all blog entries posted before the Downtime (prior to October 2011), the emoticons do not work. Case in point:

Posted Image

(I just randomly stole an old blog entry that I knew had emotes in it. :P)

Anyway, I am confused as to why they are broken, and wonder if that can be fixed. The copied entries from the old board refer to .gif files, which is what the emoticons from the old board are. However, the emoticons in the archive work, which means that the files still exist. Is there a reasonable way to make that accessible to the blog entries so the emotes will display?

I also note, if it helps, that the emotes for the new board are a different file type. They are PNGs.

As you said, the old emoticons are GIF files, while on the new board they're PNGs. The emoticons use a relative file path, so they're looking for the GIF files in the /board directory, which only has the PNG files.

I can look into copying the GIF files to the new instance, but I just need to make sure that doing so won't mess up the new emoticons.

Theoretically if you copy in .gif files with .png it won't overwrite anything, it'll just be added space. Just my $0.02 USD.

Yes, but I want to make sure the software doesn't try to start using the GIFs again and some posts have PNG emoticons and others use GIF.

If the file saying which string corresponds to which emoticon makes no mention of the GIF ones, there should be no problem.

-Gata Posted Image


So it turns out the images were there - that wasn't the problem. It problem was the directory in which they were stored has changed, which meant the old blog entries that were pointing at the old files couldn't find them. I've made a copy of the images in the directory the old blog entries are looking for and I'm seeing emoticons in the entries now.

locked issue





0 user(s) are reading this issue

0 members, 0 guests, 0 anonymous users