Jump to content

  • Log in with Facebook Log in with Twitter Log In with Google      Sign In   
  • Create Account

Welcome to BZPower!

Hi there, while we hope you enjoy browsing through the site, there's a lot more you can do if you register. The process is easy and you can use your Google, Facebook, or Twitter account to make it even faster. Some perks of joining include:
  • Create your own topics, participate in existing discussions, and vote in polls
  • Show off your creations, stories, art, music, and movies and play member and staff-run games
  • Enter contests to win free LEGO sets and other prizes, and vote to decide the winners
  • Participate in raffles, including exclusive raffles for new members, and win free LEGO sets
  • Send private messages to other members
  • Organize with other members to attend or send your MOCs to LEGO fan events all over the world
  • Much, much more!
Enjoy your visit!

Issue Information

  • #000042

  • Issue

Issue Confirmations

  • Yes (8)No (4)
Locked 
Photo

Teleporting cursor

Posted by ~Shockwave~ on Nov 19 2012 - 06:32 PM

most of you know what I mean. If you do not, it's when the cursor will jump back somewhere for no apparent reason while you're typing.
I'm aware there are ways to avoid it, but having to edit it in that way is tedious and frustrating. especially when you don't have the BBCodes memorized.

Are you talking about when you backspace and the curser will go back to a previous part of the post? It appears to do that for things like italics. For example you'll type in italics then continue typing, and when you backspace, it jumps back to the italics part. Is that like what you're talking about?

Edited by Velox, Nov 20 2012 - 02:03 AM.



~Shockwave~
Nov 19 2012 09:27 PM
yes. that's exactly what I mean. and I use Italics a lot. I find them logical.

yup. It just did it.

I type BBCode into the RTF editor instead of hitting the italics button or whatever.

[i]italics text here[/i]

Always works, never get the backspace issue. :shrugs:


JrMasterModelBuilder
Nov 20 2012 01:59 PM
Here's how to recreate the issue.
  • Type: "This is an italics test."
  • Using the cursor keys, move the insertion point to the start of "italics".
  • Holding down shift, press the right cursor key to select the entire word.
  • Press Ctrl + i (OSX: CMD + i) to italicize the text then press the left cursor key twice and the insertion point will jump from the left of the word to the second to last character of the word.



Colette Llyan
Nov 20 2012 03:33 PM
JMMB: That's a glitch? I thought it was supposed to do that. Since it does that for anything that's highlighted in a text box, IIRC...

That said; I'm not seeing any glitches personally; aside from it moving up sometimes, but that's typically from my touchpad selecting a spot by accident. So, therefore, my counter question is, are you guys using a laptop? If so, you could accidentally be left clicking, if your touchpad's set up to also left click if you tap it.

Thanks for those steps JMMB. This is definitely a glitch. I'll open a ticket with Invision.

Actually I've never encountered that issue before, @ JMMB, but I've never tried it either. =P What I was talking about is, when, you're typing a sentence and while you're typing you use (Ctrl+I) to make one word italics, then (Ctril+I) again to continue typing in normal text. If you backspace after that, the cursor will jump back to the italicized text.

Example:

This is a sentence with italicext. tx

Basically, I was pretending that I accidentally placed the "x" in "text" before the "e" -- so I pressed the backspace once and continued typing "ext", but at that point the cursor had moved back to the italics text, creating the above.

@ BZP Blade ~ Nope -- I use a laptop, but I also use a keyboard/mouse often, so there's no way that I am pressing the touchpad.

Edited by Velox, Nov 20 2012 - 05:21 PM.



JrMasterModelBuilder
Nov 20 2012 05:23 PM

JMMB: That's a glitch? I thought it was supposed to do that. Since it does that for anything that's highlighted in a text box, IIRC...

That said; I'm not seeing any glitches personally; aside from it moving up sometimes, but that's typically from my touchpad selecting a spot by accident. So, therefore, my counter question is, are you guys using a laptop? If so, you could accidentally be left clicking, if your touchpad's set up to also left click if you tap it.

Yes I am using a laptop, but I've ruled out the track pad (which was what I initially thought must have been the problem). On the first press of the left cursor key, the cursor moving to the point before "italics" is expected, but pressing the cursor key again results in the insertion point moving between the "c" and "s" of "italics". I've seen it happen other ways as well, I just don't know what key strokes triggered it.

EDIT: Velox just listed one. It wouldn't surprise me if they are all related.

Edited by JrMasterModelBuilder, Nov 20 2012 - 05:25 PM.


I heard this happens because you accidentally delete some of the BBcode tags in the rich text editor, and it goes insane.


Colette Llyan
Nov 20 2012 05:34 PM
JMMB: Hmm. Yeah, I get what you mean now. To me, it seems as if it's trying to set the cursor at the end of the word for that case, and then pressing left puts it where it thinks it should go. But testing in notepad shows that it indeed doesn't function that way outside of BZP... I guess I don't use that method that much. >>' That's the only extent I've personally seen, though... Maybe it's because I usually type out the BBC. =/

Velox: That's odd. I tried to test it myself, but... Do you press right after pressing Ctrl+I? Because when I press it a second time, it reverts the text back to normal, as it should. And if you press right, it starts the italics back up. And alright; just ruling that out.

Press right? As in, the right arrow key? If so, then no. All I do is continue typing, but press the backspace key at one point. When I press Ctrl+I for a second time, it reverts back to the normal text. So I'll keep typing (the one word of italics being the only word in italics). The problem is, if I backspace, the cursor will jump back to the italics text.

This is a documented issue on the version of the software we're using. It should be fixed in the next release.

This looks like it's resolved now. Can anyone reproduce?

Yeah, looks like it's fixed for me. 


~Shockwave~
Nov 30 2012 05:05 PM
testing testing
testing
 
appears to work! no teleportation while typing any of that!

locked issue





0 user(s) are reading this issue

0 members, 0 guests, 0 anonymous users