Jump to content

  • Log in with Facebook Log in with Twitter Log In with Google      Sign In   
  • Create Account

Welcome to BZPower!

Hi there, while we hope you enjoy browsing through the site, there's a lot more you can do if you register. The process is easy and you can use your Google, Facebook, or Twitter account to make it even faster. Some perks of joining include:
  • Create your own topics, participate in existing discussions, and vote in polls
  • Show off your creations, stories, art, music, and movies and play member and staff-run games
  • Enter contests to win free LEGO sets and other prizes, and vote to decide the winners
  • Participate in raffles, including exclusive raffles for new members, and win free LEGO sets
  • Send private messages to other members
  • Organize with other members to attend or send your MOCs to LEGO fan events all over the world
  • Much, much more!
Enjoy your visit!

Posted Image

Issue Information

  • #000086

  • Issue

Issue Confirmations

  • Yes (0)No (0)

Font Colors Not Working Properly

Posted by Electric Turahk on Nov 30 2012 - 11:12 PM

It seems that after the upgrade, font colors at least aren't behaving properly anymore.  Before, I used to be able to enter something like this:


Sentence two.

Sentence again.
And it would carry the color the whole way through the post.  Now, it stops at only the first line and when I go in to edit it, every line needs to have its color changed individually to fix it.

Dec 01 2012 12:05 AM
Your tags are out of order. You should close them in the same order you open them. i.e.
[color=#d4af37][b]Sentence. Sentence two. Sentence again. [s]~|ET|~[/s][/b][/color]

Edited by JrMasterModelBuilder, Dec 01 2012 - 12:06 AM.

Electric Turahk
Dec 01 2012 12:06 AM
It doesn't actually matter.  I've always been doing it that way and it's not been a problem before.
Edit: And just to verify, I previewed a post with both orderings and neither worked properly.

Edited by Electric Turahk, Dec 01 2012 - 12:11 AM.


Sentence two.

Sentence again.


Seems to work for me. Are you typing that in the rich-text editor or in the BBcode editor?

-Gata Posted Image

Edited by Gatanui, Dec 01 2012 - 08:02 AM.

Electric Turahk
Dec 01 2012 09:39 AM
There's a reason I posted this in the forum section. ;)  It doesn't appear to be a problem in the Tracker nor Blogs.
I am in the rich-text editor but because I am so accustomed to it, I simply type out the BB-code.

Edited by Electric Turahk, Dec 01 2012 - 09:42 AM.

Have you tried using the BBCode editor and seeing if that works? It seemed to do so for me.

Electric Turahk
Dec 01 2012 10:19 AM
Well it'll be a minor loss of features, but yep flipping that switch seems to work. Still find it strange that it wasn't a problem before, but oh well.

I would still consider this a problem, don't get me wrong. At least there's an easy workaround though.

I'm finding that tapping any BBCode into the RTF editor in general has been messed up since the upgrade.

I'm now getting this problem, both in the forums and blogs. Good to know there's a workaround, though.

I've entered a bug ticket with Invision on this.

Here's the official response from Invision:

Improvements in entering BBCode in RTE mode have been made in [the next version of IP.Board] but your members should be using the toolbar buttons for BBCode when in RTE mode. If they wish to manually type BBCode they will need to switch to BBCode mode using the switch button on the editor toolbar (top left).

I'll defer this and we can see what happens when we next upgrade.

Electric Turahk
Dec 12 2012 04:00 PM
Using the buttons is so slow... Especially when using a color that's not one of the defaults. Hence manually typing. "Don't do it that way" seems like a pretty poor excuse to me.

But yeah, I guess we'll see after the next upgrade. Thanks.

Using the buttons is so slow... Especially when using a color that's not one of the defaults. Hence manually typing. "Don't do it that way" seems like a pretty poor excuse to me.

But yeah, I guess we'll see after the next upgrade. Thanks.

An easy fix is to hit the lightswitch to swap to BBCode mode and do it there.

Please let me know if this issue is still happening.

Electric Turahk
Jan 05 2013 02:18 PM
Yep, still doesn't work in the rich text editor mode. BBCode mode is still fixing it though.

Edited by Electric Turahk, Jan 05 2013 - 02:19 PM.

And deferred again...

Electric Turahk
Mar 02 2013 06:30 PM

Edit: I think it's working fine now.  Granted, at least with posting, the default font style add-on sort of made this a moot point (for me). But yeah, I think we're all good.


Edited by Electric Turahk, Mar 02 2013 - 06:31 PM.

Another bug bites the dust...

locked issue

0 user(s) are reading this issue

0 members, 0 guests, 0 anonymous users